太阳城娱乐

在线检测未来函数

通达信庄家轨迹指标公式

来源:Internet,编辑:太阳城娱乐,2019-02-20

LC:=REF(CLOSE,1);
VID:=SUM(VOL,2)/((HHV(HIGH,2)-LLV(LOW,2))*100);
RC:=(CLOSE-LC)*VID;
LONG:=SUM(RC,0);
DIFF:=SMA(LONG,10,1);
DEA:=SMA(LONG,20,1);
LON:=DIFF-DEA;
LLL:=MA(LON,10);
TDXSTEP134:IF(LLL>=REF(LLL,1),LLL,DRAWNULL),COLORRED;
V2:EMA(LON,1),COLORGREEN;
V3:EMA(V2,3),COLORGREEN;
V4:EMA(V3,3),COLORGREEN;
V5:EMA(V4,3),COLORGREEN;
V6:EMA(V5,3),COLORGREEN;
TDXSTEP135:IF(V2>=REF(V2,1),V2,DRAWNULL),COLORRED;
TDXSTEP136:IF(V3>=REF(V3,1),V3,DRAWNULL),COLORRED;
TDXSTEP137:IF(V4>=REF(V4,1),V4,DRAWNULL),COLORRED;
TDXSTEP138:IF(V5>=REF(V5,1),V5,DRAWNULL),COLORRED;
TDXSTEP139:IF(V6>=REF(V6,1),V6,DRAWNULL),COLORRED;
TDXSTEP140:0,COLORWHITE;
TDXSTEP141:STICKLINE(V2>REF(V2,1),V2,REF(V2,1),3,0),COLORRED;
TDXSTEP142:STICKLINE(V2<REF(V2,1),V2,REF(V2,1),3,0),COLORGREEN;
VAR1B:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;
VAR2B:=SMA(VAR1B,9,1)+100;
VAR3B:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR4B:=SMA(VAR3B,3,1);
VAR5B:=SMA(VAR4B,3,1)+100;
VAR6B:=VAR5B-VAR2B;
VAR2Q:=REF(LOW,1);
VAR3Q:=SMA(ABS(LOW-VAR2Q),3,1)/SMA(MAX(LOW-VAR2Q,0),3,1)*100;
VAR4Q:=EMA(IF(CLOSE*1.3,VAR3Q*10,VAR3Q/10),3);
VAR5Q:=LLV(LOW,30);
VAR6Q:=HHV(VAR4Q,30);
VAR7Q:=IF(MA(CLOSE,58),1,0);
VAR8Q:=EMA(IF(LOW<=VAR5Q,(VAR4Q+VAR6Q*2)/2,0),3)/999*VAR7Q;
火焰山:=IF(VAR8Q>100,100,VAR8Q);
TDXSTEP143:STICKLINE(火焰山>0 AND 火焰山>REF(火焰山,1),0,火焰山*1.2,3.5,0),COLOR4444FF;
TDXSTEP144:STICKLINE(火焰山>0 AND 火焰山>REF(火焰山,1),0,火焰山*1.2,2.5,0),COLOR5555FF;
TDXSTEP145:STICKLINE(火焰山>0 AND 火焰山>REF(火焰山,1),0,火焰山*1.2,1.5,0),COLOR7777FF;
TDXSTEP146:STICKLINE(火焰山>0 AND 火焰山>REF(火焰山,1),0,火焰山*1.2,0.5,0),COLOR9999FF;
逃顶:=CROSS(82,RSI.RSI1);
TDXSTEP147:STICKLINE(逃顶,逃顶,10,3.5,0),COLORFF5500;
TDXSTEP148:STICKLINE(逃顶,逃顶,15,2.5,0),COLORFF8800;
TDXSTEP149:STICKLINE(逃顶,逃顶,20,1.5,0),COLORFFAA00;
TDXSTEP150:STICKLINE(逃顶,逃顶,25,0.5,0),COLORFFCC00;
TDXSTEP151:STICKLINE(逃顶,逃顶,30,0.1,0),COLORCYAN;
强弱线:50,POINTDOT,COLORGREEN;
VARR1:=SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100;
TDXSTEP152:DRAWICON(CROSS(82,VARR1),10,15);
TDXSTEP153:DRAWTEXT(CROSS(82,VARR1),35,7),COLORYELLOW;
VAR6:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR7:=SMA(ABS(VAR6-HIGH),13,1)/SMA(MAX(VAR6-HIGH,0),10,1);
VAR8:=EMA(VAR7,10);
VAR9:=HHV(HIGH,33);
VAR0:=EMA(IF(HIGH>=VAR9,VAR8,0),3);
主力出场:IF(VAR0>REF(VAR0,1),(-VAR0)+100,100),COLORGREEN;
VAR1:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR2:=SMA(ABS(LOW-VAR1),13,1)/SMA(MAX(LOW-VAR1,0),10,1);
VAR3:=EMA(VAR2,10);
VAR4:=LLV(LOW,33);
VAR5:=EMA(IF(LOW<=VAR4,VAR3,0),3);
主力进场:IF(VAR5>REF(VAR5,1),VAR5,0),COLORRED;
地量:DRAWTEXT(CROSS(0.9,1/VOL*1000>0.01 AND KDJ.J<0),LOW*1,8),COLORYELLOW;
TDXSTEP154:STICKLINE(地量>0,0,30,2,0),COLOR008888;
TDXSTEP155:STICKLINE(地量>0,0,30,1.5,0),COLOR00AAAA;
TDXSTEP156:STICKLINE(地量>0,0,30,0.8,0),COLOR00DDDD;
TDXSTEP157:STICKLINE(地量>0,0,30,0.3,0),COLORYELLOW;
TDXSTEP158:DRAWICON(CROSS(82,VARR1),10,15);
VAR10:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR11:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR12:=VAR10<REF(VAR11,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
TDXSTEP159:DRAWTEXT(VAR12 AND COUNT(VAR12,30)=1,40,9),COLORRED;
A2:=5;
A3:=(2*CLOSE+HIGH+LOW)/4;
A4:=LLV(LOW,34);
A5:=HHV(HIGH,34);
A6:=EMA((A3-A4)/(A5-A4)*100,13);
A7:=EMA(0.667*REF(A6,1)+0.333*A6,2);
庄家轨迹:EMA(A7,A2),COLORRED;
A8:=HHV(HIGH,9)-LLV(LOW,9);
A9:=HHV(HIGH,9)-CLOSE;
A10:=CLOSE-LLV(LOW,9);
A11:=A9/A8*100-70;
A12:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
A13:=SMA(A10/A8*100,3,1);
A14:=SMA(A13,3,1)-SMA(A11,9,1);
A15:=IF(A14>100,A14-100,0);
A16:=EMA((A3-A4)/(A5-A4)*100,8);
A17:=EMA(A16,5);
A18:=EMA(CLOSE,2);
A19:=EMA(SLOPE(CLOSE,21)*20+CLOSE,42);
A20:=HHV(MA(HIGH,13),13);
A21:=LLV(MA(HIGH,13),1);
A22:=EMA(CLOSE,4);
A23:=A18>=A19 AND A21=A20 AND A18>A22 AND CLOSE>A21 AND REF(A21,1)<REF(A20,1);
A24:=BARSLAST(A23)+1;
A25:=LLV(LOW,A24)*1.3;
A26:=LLV(LOW,20)*1.418;
A27:=A18>=A19 AND A21=A20 AND CLOSE/REF(CLOSE,1)>=1.07 AND A24<=30 AND CLOSE<=A25 AND CLOSE<=A26;
A28:=A27 AND FILTER(A27,A24);
A30:=A18>=A19 AND A21=A20 AND CLOSE/REF(CLOSE,1)>=1.035 AND A24<=30 AND CLOSE<=A25 AND CLOSE<=A26;
A31:=A30 AND FILTER(A30,20);
TDXSTEP160:DRAWICON(A28 OR A31,庄家轨迹,26);
TDXSTEP161:DRAWTEXT(A28 OR A31,庄家轨迹,11),COLORRED;

通达信庄家轨迹指标公式

 

相关文章