太阳城娱乐

在线检测未来函数

通达信3种买入信号主图指标公式

来源:Internet,编辑:太阳城娱乐,2018-12-19

买点1:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
买点2:=SMA(买点1,3,1);
买点3:=SMA(买点2,3,1);
买点4:=3*买点2-2*买点3;
买点5:=C-REF(C,1);
买点6:=100*EMA(EMA(买点5,6),6)/EMA(EMA(ABS(买点5),6),6);
买点:=LLV(买点6,2)=LLV(买点6,7) AND COUNT(买点6<0,2) AND CROSS(买点6,MA(买点6,2));
STICKLINE(买点,OPEN,CLOSE,2,0),COLORYELLOW;
好线:=38,COLORFF3311,NODRAW;
平线:=51,COLORFF1155,NODRAW;
OK:=REF(CLOSE,1),NODRAW;
RSI1:=SMA(MAX(CLOSE-OK,0),7,1)/SMA(ABS(CLOSE-OK),7,1)*100,COLORWHITE,NODRAW;
RSI2:=SMA(MAX(CLOSE-OK,0),7,1)/SMA(ABS(CLOSE-OK),7,1)*100,COLORWHITE,NODRAW;
鱼:SMA(MAX(CLOSE-OK,0),7,1)/SMA(ABS(CLOSE-OK),7,1)*100,COLORMAGENTA,NODRAW;
RSI4:=SMA(鱼,7,1),LINETHICK1,COLORWHITE,NODRAW;
趋势A:=MA(((CLOSE-LLV(LOW,48))/(HHV(HIGH,48)-LLV(LOW,48))*50),17)+9,COLORFFFFFF,NODRAW;
趋势B:=MA(((CLOSE-LLV(LOW,53))/(HHV(HIGH,53)-LLV(LOW,53))*50),17)+9,COLOR3377DD,NODRAW;
趋势C:=EMA(((CLOSE-LLV(LOW,38))/(HHV(HIGH,38)-LLV(LOW,38))*50),17)+18,COLORYELLOW,LINETHICK1,NODRAW;
A1:=MA(趋势A,7)*1.372,COLORGREEN,LINETHICK1,NODRAW;
A2:=A1*1.0887;
A3:=(1.5*(趋势B+RSI4)-(A2+A1))+12,COLORGREEN,LINETHICK1,DOTLINE;
网:IF((CROSS(RSI2,RSI4) OR CROSS(RSI2,A3) AND A3<好线 AND RSI1<平线),48,38),COLORRED,LINETHICK1,DOTLINE,NODRAW;
柱:网=48 AND CROSS(鱼,好线) AND REF(MA(C,3),1)<=MA(C,3),COLORRED,NODRAW;
{STICKLINE(柱,48,68,1,0)COLORMAGENTA;}
STICKLINE(柱,OPEN,CLOSE,2,0),COLORBLUE;
阴:C>O AND MA(C,5)<MA(C,10) AND REF(C<O,1) AND REF(C<O,2) AND REF(C<O,3) AND (REF(C,1)<REF(C,4)*0.88 OR REF(C,1)<REF(O,4)*0.88)COLORGREEN,NODRAW;
{STICKLINE(阴,10,19,1,0)COLORGREEN;}
STICKLINE(阴,OPEN,CLOSE,2,0),COLORWHITE;
N:=10;
DIR:=ABS(CLOSE-REF(CLOSE,N));
VIR:=SUM(ABS(CLOSE-REF(CLOSE,1)),N);
ER:=DIR/VIR;
CS:=ER*(2/3-2/31)+2/31;
CQ:=CS*CS;
AMA1:
DMA(CLOSE,CQ),COLORGREEN,LINETHICK1;
AMA2:
IF(AMA1>REF(AMA1,1),AMA1,DRAWNULL),
COLORRED,LINETHICK1;

通达信3种买入信号主图指标公式

 

相关文章