太阳城娱乐

在线检测未来函数

大智慧的神剑指标改写成选股公式

来源:Internet,编辑:太阳城娱乐,2012-03-14

编写要求:

太阳城娱乐解答:

 网友求助:

DIFF:=EMA(CLOSE,8)-EMA(CLOSE,13);
A2:=K>D;
KDJX:IF(A2,2,0),COLORRED;
LC:=REF(CLOSE,1);
RSI1:=(SMA(MAX(CLOSE-LC,0),5,1))/(SMA(ABS(CLOSE-LC),5,1))*100;
RSI2:=(SMA(MAX(CLOSE-LC,0),13,1))/(SMA(ABS(CLOSE-LC),13,1))*100;
DRAWICON(RSI1>RSI2,3,7);
DRAWICON(RSI1<RSI2,3,8);
DRAWTEXT(0,47,'.RSI'),COLORFFFFFF;
A3:=RSI1>RSI2;
RSIX:IF(A3,3,0),COLORRED;
DRAWTEXT(0,35,'.LWR'),COLORFFFFFF;
A4:=LWR1>LWR2;
LWRX:IF(A4,4,0),COLORRED;
BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
DRAWICON(CLOSE>BBI,5,7);
DRAWICON(CLOSE<BBI,5,8);
DRAWTEXT(0,23,'.BBI'),COLORFFFFFF;
A5:=CLOSE>BBI;
BBIX:IF(A5,5,0),COLORRED;
MTM:=CLOSE-REF(CLOSE,1);
MMS:=100*EMA(EMA(MTM,5),3)/EMA(EMA(ABS(MTM),5),3);
MMM:=100*EMA(EMA(MTM,13),8)/EMA(EMA(ABS(MTM),13),8);
DRAWICON(MMS>MMM,6,7);
DRAWICON(MMS<MMM,6,8);
DRAWTEXT(0,11,'.MTM'),COLORFFFFFF;
A6:=MMS>MMM;
MTMX:IF(A6,6,0),COLORRED,LINETHICK2;
涨买入:IF((A1 AND A2 AND A3 AND A4 AND A5 AND A6) AND REF(A1 AND A2 AND A3 AND A4 AND A5 AND A6,1)=0,7,0),COLORYELLOW,LINETHICK1;
上涨:IF(A1 AND A2 AND A3 AND A4 AND A5 AND A6,7,0),COLORYELLOW,LINETHICK1;
晴天:(MACDX+KDJX+RSIX+LWRX+BBIX+MTMX=21),LINETHICK0;
雨天:(MACDX+KDJX+RSIX+LWRX+BBIX+MTMX>0 AND MACDX+KDJX+RSIX+LWRX+BBIX+MTMX<21 ),LINETHICK0;
雪天:(MACDX+KDJX+RSIX+LWRX+BBIX+MTMX=0),LINETHICK0;

请改写成两个选股公式:

1,MTMX,BBIX,LWRX,RSIX,KDJX,MACDX同时为零的选股公式;

2,MTMX为零的选股公式。
 

 
解答如下:
DIFF:=EMA(CLOSE,8)-EMA(CLOSE,13);
DEA:=EMA(DIFF,5);
A1:=DIFF>DEA;
RSV1:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
K:=SMA(RSV1,3,1);
D:=SMA(K,3,1);
A2:=K>D;
LC:=REF(CLOSE,1);
RSI1:=(SMA(MAX(CLOSE-LC,0),5,1))/(SMA(ABS(CLOSE-LC),5,1))*100;
RSI2:=(SMA(MAX(CLOSE-LC,0),13,1))/(SMA(ABS(CLOSE-LC),13,1))*100;
A3:=RSI1>RSI2;
RSV:=-(HHV(HIGH,13)-CLOSE)/(HHV(HIGH,13)-LLV(LOW,13))*100;
LWR1:=SMA(RSV,3,1);
LWR2:=SMA(LWR1,3,1);
A4:=LWR1>LWR2;
BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
A5:=CLOSE>BBI;
MTM:=CLOSE-REF(CLOSE,1);
MMS:=100*EMA(EMA(MTM,5),3)/EMA(EMA(ABS(MTM),5),3);
MMM:=100*EMA(EMA(MTM,13),8)/EMA(EMA(ABS(MTM),13),8);
A6:=MMS>MMM;
A1=0 AND A2=0 AND A3=0 AND A4=0 AND A5=0 AND A6=0;
=============
MTM:=CLOSE-REF(CLOSE,1);
MMS:=100*EMA(EMA(MTM,5),3)/EMA(EMA(ABS(MTM),5),3);
MMM:=100*EMA(EMA(MTM,13),8)/EMA(EMA(ABS(MTM),13),8);
A6:=MMS>MMM;
A6=0;

 

相关文章